McManus Center Network Service Interruption

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 19:12 CST

Identified

Northwestern Information Technology has identified a power outage causing an interruption for telephone, wired, and wireless network services at McManus Center. Facilities Management and the electrical utility provider have been engaged, and they are working on restoring power.

The next update will be provided by 20:00 CST.
Posted Mar 07, 2026 - 17:55 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).