Wirtz Center - Power & Network Service Interruption

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 12:57 CDT

Identified

Northwestern Information Technology has identified a power issue causing a service interruption to wired, wireless, and telephone services within the Wirtz Center for the Performing Arts. Facilities Management is working to resolve the issue and restore power as soon as possible.

The next update will be provided by 12:00 CDT.
Posted Jul 16, 2026 - 08:22 CDT

Investigating

Northwestern Information Technology is investigating an issue causing a service interruption to wired, wireless, and telephone services within the Wirtz Center for the Performing Arts.

The next update will be provided at 9:00 CDT.
Posted Jul 16, 2026 - 07:16 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).