Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2025 - 19:00 CDT
Scheduled
Northwestern Information Technology will be upgrading software on the Evanston Production load balancers. This work is being performed to mitigate several security vulnerabilities. This maintenance will affect those services that only utilize the Evanston Data Center Production load balancer service. Affected systems should not experience any service interruption due to the redundancy of the system. Those services include: AD Federation AD LDAP Directory Exchange/Email/ Microsoft Collaboration Services myHR: Careers myHR myHR: Reports NU Financial InfoEd NUInfo/http://www.northwestern.edu NUValidate Registry Sharepoint Splunk CAESAR Voicemail WebSSO
Posted Aug 25, 2025 - 12:24 CDT
This scheduled maintenance affected: Infrastructure (Load Balancing (Network Connectivity)).