Microsoft 365 Service Interruption
Resolved
This issue has been resolved.
If a user is still experiencing any issues it is recommended to restart their client application to restore service.
Posted Nov 26, 2024 - 12:41 CST
Update
Microsoft reports most services have been restored but still don't have an ETA for full restoration at this time.

The next update will be provided by Nov 27, 2024 - 10:00 CST
Posted Nov 26, 2024 - 10:00 CST
Update
Microsoft reports most services have been restored but does not have an ETA for full restoration at this time.

The next update will be provided by Nov 26, 2024 - 10:00 CST
Posted Nov 25, 2024 - 13:27 CST
Update
Microsoft continues work to fully restore services. At this time some service restoration has been reported.

The next update will be provided by 14:00 CST.
Posted Nov 25, 2024 - 12:06 CST
Identified
Northwestern Information Technology has identified an issue with Microsoft 365 impacting a subset of services.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 12:00 CST.
Posted Nov 25, 2024 - 10:01 CST
This incident affected: Communication and Collaboration (Office 365 (Email and Calendaring)).