2133 Sheridan, Ford: Network Service Interruption

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 18:18 CST

Identified

Northwestern Information Technology has been informed by Facilities Management of a power interruption at the Ford building. Facilities Management is working to restore power. Until power is fully restored, network services at this location may be affected.

2133 Sheridan Ford

The next update will be provided by 18:00 CST.
Posted Jan 26, 2026 - 15:49 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).