The generator repair has been rescheduled to Tuesday, 12/23/2025 from 12:00 PM to 3:00 PM.
Posted Dec 14, 2025 - 09:52 CST
Scheduled
As part of a critical repair for the generator that serves Abbott Hall, Northwestern Information Technology will be installing new batteries on Tuesday, 12/23/2025. During this time no service interruptions are expected, but the following services will be operating a reduced level of power redundancy for the duration of the maintenance window from 12:00 PM to 3:00 PM:
Wired/Wireless Data Networking Telephone/Voice Services Internet Services
There will be a generator run after the installation of the new batteries has been completed to verify that the generator is functional.
If there is an unexpected loss of utility power during this work, there may be campus-wide impacts to services beyond just Abbott Hall.
Posted Dec 11, 2025 - 07:16 CST
This scheduled maintenance affects: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity), Internet Network Services (Network Connectivity)).