1819 Hinman Avenue Network Service Interruption

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 10:18 CDT

Update

We are continuing to investigate this issue and we have not yet received a projected resolution time.

The next update will be provided by Monday 9:00 CDT.
Posted Oct 11, 2025 - 07:26 CDT

Update

We are continuing to investigate this issue and we have not yet received a projected resolution time.

The next update will be provided by Monday, October 13, 2025 at 9:00 CDT
Posted Oct 10, 2025 - 18:24 CDT

Investigating

Northwestern Information Technology has identified an issue with power impacting a subset of services at the posted location.

Facilities Management has been informed and are investigating to restore full service as quickly as possible.

While they are working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 6:30 CDT
Posted Oct 10, 2025 - 17:19 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity), Internet Network Services (Network Connectivity)).