Smartsheet Service Interruption

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 18:41 CDT

Monitoring

The vendor has implemented a fix and are monitoring the results.

The next update will be provided by 14:30 CDT.
Posted Oct 14, 2025 - 13:14 CDT

Investigating

Northwestern Information Technology is investigating an issue with Smartsheet impacting a subset of services. The vendor has received reports that sheet attachments are not accessible for users and are investigating further.

The next update will be provided by 13:00 CDT.
Posted Oct 14, 2025 - 12:07 CDT
This incident affected: Administrative and Business (Smartsheet).