Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2024 - 19:00 CST
Scheduled
Northwestern Information Technology is performing work as part of a Facilities project to renovate the Jacobs Center (details are at https://www.northwestern.edu/facilities/_projects/social-science-global-hub.html). We are cutting, relocating, and resplicing fiber optic cables during this maintenance window. Network connectivity, including VoIP phone, wireless, and wired services, will be affected for the given time frame for the buildings listed below.
1800 Sherman 2020 Ridge 1603 Orrington 800 Elgin 1007 Church
Posted Nov 25, 2024 - 16:02 CST
This scheduled maintenance affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).