Workforce Software Performance Degradation

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 10:36 CDT

Monitoring

The vendor has resolved the issue and services have been restored to normal operation.
The vendor will continue monitoring the environment.

Next update will be provided once it's available
Posted Aug 13, 2026 - 17:35 CDT

Investigating

The vendor Workforce Software (WFS) has notified us of Performance Degradation that may cause slowness, elevated response times, login delays, or inability to access the system

Next update will be provided once it's available
Posted Aug 13, 2026 - 15:36 CDT
This incident affected: Administrative and Business (Workforce Software (WFS) Timekeeping (Human Resources Systems)).