Services have been fully restored. This incident is resolved.
Posted Nov 05, 2025 - 12:30 CST
Update
Service owners and support staff continue to see improvements in performance and there have been no additional reports of issues.
Monitoring of services will continue until all services are confirmed to be fully restored.
The next update will be provided by 13:30 CST.
Posted Nov 05, 2025 - 11:32 CST
Identified
Services began showing improvements at 9:45 CST after completion of additional mitigations. Northwestern Information Technology and service owners will continue to monitor services until all are fully restored.
The next update will be provided by 11:30 CST.
Posted Nov 05, 2025 - 10:15 CST
Investigating
Northwestern Information Technology is investigating reports from across both Evanston and Chicago Campuses of intermittent network slowness. This is impacting services/applications that are hosted in the University Data Center.
Northwestern IT engineers are engaging vendors for Data Center and Campus Network Infrastructure.
The next update will be provided by 11:00 CST.
Posted Nov 05, 2025 - 09:20 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).