Duo Authentication Service Interruption

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 12:52 CST

Monitoring

The vendor has confirmed this incident is resolved.

Northwestern Information Technology will continue to monitor services to ensure all affected Northwestern services are fully restored.


The next update will be provided by 13:00 CST
Posted Feb 23, 2026 - 11:56 CST

Update

Northwestern IT continues to monitor the vendor issue impacting the availability of Duo Multi-factor Authentication.

To minimize the disruption to students registering for spring classes today, we have implemented a temporary workaround for CAESAR.

The next update will be provided by 12:00 CST.
Posted Feb 23, 2026 - 10:39 CST

Update

Northwestern is impacted by an issue affecting Duo Multi-factor Authentication. The issue specifically impacts Microsoft-based authentication, including CAESAR, Canvas, myHR, NUFinancials, Teams, Sharepoint, and Exchange email. When attempting to authenticate with Duo, users are experiencing a 504 timeout message. Services that use WebSSO are not impacted.

The vendor is working to resolve this issue as quickly as possible. However, we have not yet received a projected resolution time.

The next update will be provided by 11:00 CST
Posted Feb 23, 2026 - 09:37 CST

Identified

Northwestern Information Technology has identified an issue and Duo is unavailable.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 10:00 CST.
Posted Feb 23, 2026 - 09:04 CST
This incident affected: Identity and Access Management (Duo Core Authentication Service (Authentication and Authorization Services)).