Northwestern Information Technology continues to work with carriers to resolve this issue.
Next update will be made by 15:00 CST on Wednesday, January 22.
Posted Jan 21, 2025 - 12:39 CST
Update
Northwestern Information Technology continues to work with carriers to resolve this issue.
Next update will be made by 15:00 CST on Tuesday, January 21st.
Posted Jan 17, 2025 - 14:53 CST
Identified
Northwestern Information Technology continues to work with carriers to resolve this issue.
Next update will be made by 15:00 CST on Friday, January 17.
Posted Jan 16, 2025 - 14:08 CST
Investigating
Northwestern Information Technology is investigating reports of varying levels of intermittent static and audio distortion on some inbound telephone calls. This appears to be the same issue experienced in July and August of 2024 where calls primarily from T-Mobile and Verizon telephone lines experienced this behavior. We are working with our local telephone service carrier to verify the root cause and resolve the issue.
The next update will be made by 10:00 CST on Thursday, January 16th.
Posted Jan 15, 2025 - 14:07 CST
This incident affects: Voice Services (Telephone Services (Videoconferencing and Telephones)).