Cooling capacity is still reduced for the Chicago Data Center but temperatures have remained stable. We will remain in this state of reduced cooling capacity until parts arrive and repairs are completed by our mechanical service provider.
The next update will be provided by 16:00 CST.
Posted Mar 07, 2026 - 13:46 CST
Update
Cooling capacity is still reduced for the Chicago Data Center but temperatures have remained stable. We will remain in this state of reduced cooling capacity until parts arrive and repairs are completed by our mechanical service provider.
The next update will be provided on Saturday by 6:00 CST.
Posted Mar 07, 2026 - 02:00 CST
Update
Cooling capacity is still reduced for the Chicago Data Center but temperatures have remained stable. We will remain in this state of reduced cooling capacity until parts arrive and repairs are completed by our mechanical service provider.
The next update will be provided on Saturday by 2:00 CST.
Posted Mar 06, 2026 - 22:17 CST
Identified
Northwestern Information Technology has investigated and identified an issue causing a state of reduced cooling capacity for the Chicago Data Center. We will remain in this state of reduced cooling capacity until parts arrive and repairs are completed.
The next update will be provided by 22:30 CST.
Posted Mar 06, 2026 - 20:29 CST
This incident affects: Infrastructure (Cooling Systems (Data Center Facilities)).