(29699) University Telephone Services Maintenance Evanston Campus
Scheduled for May 7, 19:00 - 23:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 29, 2024 - 09:59 CDT
Scheduled
Northwestern IT will be performing configuration changes on the university telephone system to enhance security. This work may cause a service interruption of ~10 minutes for some analog telephone lines on the Evanston campus. Analog telephone lines are used for applications such as fax machines, modems, and elevator phones among others. Regular Voice over IP telephones in workspaces and conference rooms will not be affected.
Posted Apr 05, 2024 - 14:11 CDT
This scheduled maintenance affects: Voice Services (Telephone Services (Videoconferencing and Telephones)).