Talkdesk Service Interruption

Resolved

This issue is resolved.

There have been no service interruptions reported by Northwestern Talkdesk users.

Talkdesk reports they have implemented a fix and services have restored.
Posted Jan 26, 2026 - 12:52 CST

Identified

Talkdesk has identified root cause of the issue and is implementing a fix at this time.

Additional details can be found here: https://status.talkdesk.com/

Next update till be by 14:00 CST
Posted Jan 26, 2026 - 12:37 CST

Investigating

Northwestern Information Technology is investigating an issue with Talkdesk which make affecting incoming and outgoing calls.

Our service provider is working to restore services.

Next update will be by 13:30 CST
Posted Jan 26, 2026 - 12:32 CST
This incident affected: Voice Services (Call Centers (Videoconferencing and Telephones)).