Earlier this evening, Canvas was restored and is available to the University community.
Currently, two University services remain impacted by the global AWS issue. At this time, Qualtrics continues to report degraded service and Smartsheet reports it has recovered from the earlier interruption but will continue monitoring to ensure the service remains stable. The Northwestern IT Service Operation Center will also monitor the status of Qualtrics and Smartsheet throughout the evening.
The next update will be provided at 07:00 CDT on Tuesday, October 21, unless both services are restored before that time.
Posted Oct 20, 2025 - 20:45 CDT
Update
Northwestern IT continues to monitor the global AWS issue impacting some University services. At this time, Canvas, Qualtrics, and Smartsheet remain impacted.
We continue to work with our vendors to understand the various restoration times for these services. Thank you for your patience.
The next update will be provided by approximately 20:30 CDT.
Posted Oct 20, 2025 - 17:43 CDT
Update
Northwestern IT continues to monitor the global AWS issue impacting some University services. At this time, Canvas, Qualtrics, and Smartsheet continue to be impacted.
However, we have confirmed that Zoom and Panopto are now restored. We continue to work with our vendors to understand the various restoration times for other services.
The next update will be provided by approximately 18:00 CDT.
Posted Oct 20, 2025 - 16:27 CDT
Update
Northwestern IT continues to monitor the global AWS issue impacting some University services. At this time, Canvas, Qualtrics, Smartsheet, Panopto, and Zoom continue to be impacted.
We continue to work with our vendors to understand the various restoration times for other services.
The next update will be provided by approximately 17:00 CDT.
Posted Oct 20, 2025 - 15:29 CDT
Update
Northwestern IT continues to monitor the global AWS issue impacting some University services. At this time, Canvas, Qualtrics, Smartsheet, Panopto, and Zoom continue to be impacted.
However, we have confirmed the Talkdesk service is now restored. We continue to work with our vendors to understand the various restoration times for other services.
The next update will be provided by approximately 16:00 CDT.
Posted Oct 20, 2025 - 14:33 CDT
Update
We continue to monitor the global AWS issue impacting Canvas, Qualtrics, Talkdesk, Smartsheet, and Panopto. At this time, Zoom is also now reporting degraded performance with some of its primary components, including meetings, chat, and other ancillary tools.
We continue to work with our vendors to understand the various restoration times.
The next update will be provided by approximately 15:00 CDT.
Posted Oct 20, 2025 - 13:36 CDT
Update
We continue to monitor the global AWS issue impacting Canvas, Qualtrics, Talkdesk, Smartsheet, and Panopto. We are working with our vendors to understand the various restoration times.
The next update will be provided by 14:00 CDT.
Posted Oct 20, 2025 - 12:48 CDT
Identified
As of 10:43am CDT Amazon has identified a root cause underlying the issue. It is related to network monitoring infrastructure in the us-east-1 (N. Virginia) region. Amazon is currently throttling requests for new resources, including EC2 instances, while they work on remediating the underlying issue.
The next update will be provided by 13:00 CDT.
Posted Oct 20, 2025 - 11:05 CDT
Investigating
Northwestern IT is monitoring an issue with Amazon Web Services (AWS), which is experiencing a global service outage. Several University services are hosted on AWS, including Canvas, Qualtrics, Smartsheet, Panopto, and Talkdesk. The impact on these services varies from slow response times to complete unavailability. Our software vendors are closely monitoring AWS’s recovery efforts and working to restore full functionality as quickly as possible.
For ongoing updates, please visit status.aws.amazon.com and the vendor's status pages
This incident affected: Teaching and Learning Systems (Canvas (Digital Learning Tools), Panopto (Digital Learning Tools)), Voice Services (Call Centers (Videoconferencing and Telephones)), Software and Applications (Qualtrics (Research Tools)), Communication and Collaboration (Zoom Video Conferencing (Videoconferencing and Telephones), Zoom Web Portal (Videoconferencing and Telephones)), and Administrative and Business (Smartsheet).