Oracle PeopleSoft Service Interruption

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 16:26 CDT

Identified

Oracle has released high-priority patches that Northwestern Information Technology will be applying starting at 12:00 CDT on 6/17/26 for myHR, CAESAR, and NUFinancials. Users may be logged out of systems but will be able to log back in immediately to reconnect. The next update will be posted by 17:00 CDT.
Posted Jun 17, 2026 - 11:29 CDT
This incident affected: Administrative and Business (CAESAR (Student Information Systems), myHR (Human Resources Systems), NUFinancials (Finance and Procurement Systems)).