CERES Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for CERES.
Posted May 29, 2026 - 17:00 CDT

Identified

Northwestern Information Technology has identified an issue with CERES impacting a subset of services.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided around 17:00 CDT.
Posted May 29, 2026 - 15:56 CDT

Update

Northwestern Information Technology is investigating an issue with CERES impacting a subset of services.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 16:00 CDT
Posted May 29, 2026 - 14:51 CDT

Investigating

Northwestern Information Technology is investigating an issue with CERES impacting a subset of services.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 15:00 CDT
Posted May 29, 2026 - 13:45 CDT
This incident affected: Administrative and Business (CERES (Research Administration Systems)).