Facilities Connect Service Interruption
Resolved
Northwestern Information Technology confirms the incident has been resolved for Facilities Connect.
Posted Jun 19, 2024 - 06:14 CDT
Monitoring
Northwestern Information Technology has monitored a recovery of services for Facilities Connect. Support staff will continue to test and monitor.

The next update will be provided by 7:00 CDT.
Posted Jun 19, 2024 - 06:10 CDT
Investigating
Northwestern Information Technology has identified a service interruption with Facilities Connect. The vendors has been contacted and troubleshooting is underway. Support staff will monitor the status of Facilities Connect overnight and provide status updates as they become available.

The next update will be posted on Tuesday by 6:00 CDT
Posted Jun 19, 2024 - 00:22 CDT
This incident affected: Administrative and Business (Facilities Connect (Facilities)).