Evanston Campus Network Equipment - Power Interruption

Resolved

This incident has been resolved. Power is back to normal.
Posted Jun 10, 2026 - 21:50 CDT

Identified

Northwestern Information Technology has identified a utility power disruption affecting portions of the Evanston campus. At this time, all IT services remain operational; however, power redundancy is currently unavailable.

Potentially impacted services include network connectivity, VoIP telephony, wireless networking, and wired network services.

next update by 20:00 CDT.
Posted Jun 10, 2026 - 16:28 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).