Service Management Platform Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for Service Management Platform.
Posted Nov 06, 2025 - 13:47 CST

Monitoring

Northwestern Information Technology is seeing improvement in service delivery for Service Management Platform and will continue to monitor until the issue is resolved and service is fully restored.

Updates are being provided by the vendor via https://status.teamdynamix.com/incidents/c6hr6gf8fddj

The next update will be provided by 15:00 CST.
Posted Nov 06, 2025 - 13:35 CST

Identified

Northwestern Information Technology has identified an issue with Service Management Platform impacting a subset of services.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The vendor is posting updates via https://status.teamdynamix.com/incidents/c6hr6gf8fddj

The next update will be provided by 14:30 CST.
Posted Nov 06, 2025 - 13:28 CST
This incident affected: Professional Services (Service Management Platform (Service Delivery and Support)).