Rebecca Crown Center Network Service Interruption

Resolved

Northwestern Information Technology confirms that the incident has been resolved.

Service was restored at 8:30 CDT.
Posted Mar 28, 2025 - 08:49 CDT

Investigating

Northwestern Information Technology is investigating a service interruption affecting wired, wireless, and telephone services at Rebecca Crown Center. A technician has been dispatched to investigate and resolve the service interruption.

The next update will be provided by 9:00 CDT.
Posted Mar 28, 2025 - 08:18 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).