Graduate Student Tracking System Unavailable Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved for Graduate Student Tracking System.
Posted Oct 18, 2024 - 11:58 CDT
Update
Support staff continue working to restore services.

The next update will be provided by 12:30 CDT.
Posted Oct 18, 2024 - 10:53 CDT
Identified
Northwestern Information Technology has identified an issue with Graduate Student Tracking System Unavailable impacting a subset of services.

IT support staff are working to restore full service as quickly as possible.

The next update will be provided by 11:00 CDT.
Posted Oct 18, 2024 - 09:46 CDT
This incident affected: Administrative and Business (Grad Student Tracking System (Student Information Systems)).