Power Interruption - Technical Institute

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 08:01 CST

Identified

Northwestern IT has identified a power fluctuation at the Technical Institute that may affect networking equipment - field technicians have been dispatched to investigate and troubleshoot any emerging issues.
The following rooms within the Tech Institute are under investigation:
-M317
-M422
-MG17
-LG83
-CG11
The next update will be provided by 0800 CDT.
Posted Nov 26, 2025 - 04:52 CST
This incident affected: Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).