Evanston Campus Wireless Networking Interruption

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 19:31 CDT

Update

Northwestern IT is working to apply a software update that may take several hours to complete. During this time, users may continue to experience intermittent connectivity as the update is applied.

The next update will be provided by 22:00 CDT
Posted Apr 08, 2026 - 15:07 CDT

Identified

Northwestern Information Technology has identified the root cause and is implementing a fix at this time. Connectivity may be intermittent until the fix has been fully completed.

The next update will be provided by 15:00 CDT
Posted Apr 08, 2026 - 13:52 CDT

Investigating

Information Technology support teams are investigating reports of wireless networking issues on the Evanston Campus.

The next update will be provided by 14:00 CDT
Posted Apr 08, 2026 - 13:05 CDT
This incident affected: Infrastructure (Wireless Network Services (Network Connectivity)).