Chicago Wireless Network Connectivity Issues

Resolved

Northwestern University IT has completed investigating the network connectivity issues at the Chicago campus. Functionality is confirmed to be restored as of 10:20 AM CST.
Posted Feb 17, 2026 - 10:25 CST

Investigating

Northwestern University IT has received several reports of wireless network connectivity issues at the Chicago campus, and is investigating any possible service outages.

The next update will be provided by 11:00 AM CST
Posted Feb 17, 2026 - 08:22 CST
This incident affected: Infrastructure (Wireless Network Services (Network Connectivity)).