Central Utility Plant Network Service Interruption

Resolved

The incident has been resolved.
Posted Oct 16, 2025 - 10:23 CDT

Investigating

Northwestern Information Technology has identified an issue with wired, wireless, and telephone services at Central Utility Plant. Northwestern Information Technology will be dispatching a technician to investigate this issue.

Central Utility Plant 2026 N CAMPUS DR

The next update will be provided by Thursday October 16 at 11:00 CDT.
Posted Oct 16, 2025 - 08:07 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).