Power Interruption at 1870 Sheridan Road and 555 Clark Street
Resolved
Northwestern Information Technology has been informed that ComEd has restored power at the posted locations as of 00:25 CST and all services are working as expected.
Posted Nov 19, 2023 - 01:03 CST
Update
Northwestern Information Technology has been informed that ComEd is still working on restoring power at the posted locations.

The next update will be provided by 2:30 CST.
Posted Nov 18, 2023 - 23:28 CST
Identified
Northwestern Information Technology has identified a power outage causing a service interruption. A transformer has failed. Facilities Management and ComEd have been engaged, and are working on restoring power. The following buildings are affected by this outage:

1870 Sheridan Road
555 Clark Street

The next update will be provided by 23:30 CST.
Posted Nov 18, 2023 - 22:00 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).