All services are operational at this time. Northwestern Information Technology will continue to monitor services for any additional issues.
The next update will be provided by Thursday, October 30th at 9:00 CDT
Posted Oct 29, 2025 - 20:52 CDT
Update
Microsoft has not yet announced this issue fully resolved.
Northwestern Information Technology will continue to monitor services.
The next update will be provided by Thursday, October 30th at 9:00 CDT
Posted Oct 29, 2025 - 19:01 CDT
Update
Microsoft has not yet announced this issue fully resolved.
Northwestern Information Technology will continue to monitor services.
The next update will be provided by 19:00 CDT
Posted Oct 29, 2025 - 16:58 CDT
Monitoring
Microsoft has implemented a fix, and services are beginning to restore. Users may experience some residual slowness as services return to normal operating status.
Northwestern Information Technology will continue to monitor services.
The next update will be provided by 17:00 CDT.
Posted Oct 29, 2025 - 14:10 CDT
Update
The vendor continues work to restore services to normal operation.
The next update will be provided by 14:30 CDT.
Posted Oct 29, 2025 - 13:22 CDT
Update
Northwestern IT continues working with vendor to resolve an issue affecting Microsoft Azure (Cloud Service). Some additional details are included below:
New logins to services behind Entra ID, such as Zoom, Canvas, Microsoft 365 (Email and Calendaring), CAESAR, NUFinancials, myHR and others, may experience slowness to access. However, although the login process is slow, once the application is accessed, performance appears to be normal.
We will continue to monitor the issue and provide updates from Microsoft.
The next update will be provided by 13:30 CDT.
Posted Oct 29, 2025 - 12:31 CDT
Identified
Northwestern Information Technology has identified an issue causing a service interruption to Microsoft Azure (Cloud Service), and that is affecting services behind Entra ID logins such as Office 365 (Email and Calendaring) and possibly other services and resources.
The next update will be provided by 12:30 CDT.
Posted Oct 29, 2025 - 11:46 CDT
This incident affected: Infrastructure (Microsoft AZURE (Cloud Service)).