Cayosoft Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for Cayosoft Service.
Posted Oct 28, 2025 - 10:46 CDT

Update

Northwestern Information Technology is continuing to investigate an issue causing a service interruption to Cayosoft. The vendor has been engaged for this issue.

The next update will be provided by 11:30 CDT.
Posted Oct 28, 2025 - 10:23 CDT

Investigating

Northwestern Information Technology is investigating an issue causing a service interruption to Cayosoft.

The next update will be provided by 10:30 CDT.
Posted Oct 28, 2025 - 09:20 CDT
This incident affected: Identity and Access Management (Active Directory (Directory Services)).