ComEd and Facilities have completed repairs needed to restore power. Northwestern IT has scheduled field technicians to inspect network equipment effected by the power bump.
60 Arts Drive
The next update will be made by 10:00 Thursday, September 17th.
Posted Sep 17, 2025 - 19:02 CDT
Update
ComEd and Facilities have completed repairs needed to restore power. Northwestern IT has scheduled field technicians to inspect network equipment effected by the power bump.
60 Arts Drive
The next update will be made by 10:00 Thursday, September 17th.
Posted Sep 17, 2025 - 19:01 CDT
Update
ComEd and Facilities are continuing to work on repairs needed to restore power, and some buildings have started to come back up. Northwestern IT is making sure network equipment has come back online as expected.
60 Arts Circle Drive
The next update will be at 18:00 CDT.
Posted Sep 17, 2025 - 14:39 CDT
Update
ComEd and Facilities are continuing to work on repairs needed to restore power, and some buildings have started to come back up
The next update will be at 14:30 CDT
Posted Sep 17, 2025 - 13:36 CDT
Identified
ComEd and Facilities are continuing to work on repairs needed to restore power.
1999 Campus Dr. 1823 Campus Dr. 2026 N. Campus Dr. 60 Arts Circle Dr 1937 Sheridan 1949 Campus Dr.
The next update will be at 13:30 CDT
Posted Sep 17, 2025 - 12:31 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).