Faculty Recruitment System Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved for Faculty Recruitment System (Human Resources Systems). Service was fully restored at 10:00 CDT.
Posted Jul 08, 2024 - 10:10 CDT
Identified
Northwestern Information Technology has identified an issue with the Faculty Recruitment System (Human Resources Systems). FRS service is unavailable.

Support staff are working to restore service as quickly as possible.

The next update will be provided by 14:00p CDT.
Posted Jul 08, 2024 - 10:04 CDT
This incident affected: Administrative and Business (Faculty Recruitment System (Human Resources Systems)).