ComEd Power Bump on Evanston Campus ~ Service Interruption

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 17:57 CDT

Update

ComEd and Facilities are continuing to work on repairs needed to restore power.

1841 Sheridan
1937 Sheridan
60 Arts Circle Dr

The next update will be provided by 18:00 CDT
Posted Sep 13, 2025 - 15:21 CDT

Update

ComEd and Facilities are continuing to work on repairs needed to restore power.

1841 Sheridan
1999 Campus Dr.
1823 Campus Dr.
2026 N. Campus Dr.
60 Arts Circle Dr
1937 Sheridan
1949 Campus Dr.

Next update by 3:00 CDT
Posted Sep 13, 2025 - 13:00 CDT

Update

ComEd and Facilities continue to work to restore power. Next update by 1:00 CDT
Posted Sep 13, 2025 - 11:01 CDT

Identified

Northwestern Information Technology has identified a ComEd Power Bump for the following buildings

ComEd is working to restore full service as quickly as possible.

1841 Sheridan
1999 Campus Dr.
1823 Campus Dr.
2026 N. Campus Dr.
60 Arts Circle Dr
1937 Sheridan

The next update will be provided by 11:00 CDT
Posted Sep 13, 2025 - 10:02 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).