Office 365 (Email and Calendaring) Degraded Performance

Resolved

The vendor has confirmed that this incident is now resolved. We are closing this posting.
Posted Jul 23, 2026 - 15:27 CDT

Monitoring

The vendor has confirmed that they are seeing normal performance on Office 365 (Email and Calendaring). Northwestern Information Technology will continue to monitor performance and will post a final update by 15:30 CDT.
Posted Jul 23, 2026 - 14:58 CDT

Identified

The vendor has reported degraded performance across multiple Microsoft Office 365 services within North America. The vendor has implemented mitigations to assist with the recovery of services for a subset of users, and are working to restore service for more users as soon as possible.

The next update will be provided by 14:30 CDT.
Posted Jul 23, 2026 - 13:41 CDT
This incident affected: Communication and Collaboration (Office 365 (Email and Calendaring)).