CatConnect Service Interruption

Resolved

Northwestern Information Technology has resolved this incident. We are closing this posting.
Posted Dec 15, 2025 - 15:42 CST

Identified

Northwestern Information Technology and the vendors have identified the issue is isolated to the Blackthorn Event registration module. We are continuing to work on a fix. The next update will be by 17:00 CST.
Posted Dec 15, 2025 - 14:41 CST

Investigating

Northwestern Information Technology is receiving reports that users are receiving error messages stating that "Operation failed" due to Apex rate limits being exceeded. We are currently investigating along with the vendors. The next update will be by 15:00 CST
Posted Dec 15, 2025 - 12:41 CST
This incident affected: Administrative and Business (CatConnect (Alumni and Advancement)).