Team Dynamix Degraded Performance

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 11:13 CDT

Monitoring

Northwestern Information Technology has monitored an improvement to the performance of Team Dynamix after the vendor identified and resolved the root cause of the slowness.

Staff will continue to monitor to ensure that the performance remains stable.

The next update will be provided by 11:30 CDT.
Posted Sep 09, 2026 - 10:37 CDT

Identified

Northwestern Information Technology has identified an issue with Team Dynamix that is causing a subset of services to have degraded performance.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 11:00 CDT.
Posted Sep 09, 2026 - 10:33 CDT
This incident affected: Professional Services (Service Management Platform (Service Delivery and Support)).