CatConnect (Alumni and Advancement) Service Interruption

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 13:26 CDT

Update

The vendor has applied a mitigation for this issue, but is still performing additional verification across their environments. Some users may continue to experience severe delays, intermittent errors, or difficulty accessing some services.

The next update will be provided by 13:00 CDT.
Posted Sep 16, 2026 - 11:48 CDT

Identified

Northwestern Information Technology has identified an issue causing a service interruption to CatConnect (Alumni and Advancement). Users may experience severe delays, intermittent errors, or an inability to access some services.

Although the vendor is working to resolve the issue as soon as possible, we have not yet received a projected resolution time.

The next update will be provided by 11:00 CDT.
Posted Sep 16, 2026 - 09:43 CDT
This incident affected: Administrative and Business (CatConnect (Alumni and Advancement)).