This incident has been resolved. The Internet Service Provider has restored the lost fiber network link.
Posted May 14, 2026 - 22:15 CDT
Update
The repair crew is still working to restore the lost fiber network link. There is no impact to service due to redundant connectivity.
The next update will be provided by 16:00 CDT on Friday, May 15th
Posted May 14, 2026 - 18:09 CDT
Update
The repair crew is still working to restore the lost fiber network link. There is no impact to service due to redundant connectivity.
The next update will be provided by 16:00 CDT.
Posted May 14, 2026 - 08:26 CDT
Update
The repair crew is still working to restore the lost fiber network link. There is no impact to service due to redundant connectivity.
The next update will be provided by 9:00 CDT.
Posted May 14, 2026 - 05:39 CDT
Update
The repair crew dispatched by the Internet Service Provider is now onsite and working to resolve the outage for the fiber network link. There is no impact to service due to redundant connectivity.
The next update will be provided by 5:30 CDT.
Posted May 14, 2026 - 03:35 CDT
Update
The Internet Service Provider has identified an outage along the path of the fiber network link and have engaged a repair crew to resolve the outage. There is no impact to service due to redundant connectivity.
The next update will be provided by 3:30 CDT.
Posted May 14, 2026 - 01:41 CDT
Identified
Northwestern Information Technology has engaged one of our Internet Service Providers to restore the lost fiber network link. There is no impact to service due to redundant connectivity.
The next update will be provided on Thursday by 1:30 CDT.
Posted May 13, 2026 - 23:18 CDT
Investigating
Northwestern Information Technology has monitored the loss of a fiber network link going to one of our Internet Service Providers. There is no impact to service due to redundant connectivity.
The next update will be provided by 23:30 CDT.
Posted May 13, 2026 - 22:26 CDT
This incident affected: Infrastructure (Internet Network Services (Network Connectivity)).