Faculty Recruitment System (Human Resources Systems) Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for Faculty Recruitment System (Human Resources Systems).
Posted Mar 07, 2025 - 12:15 CST

Investigating

Northwestern Information Technology is investigating an issue causing a service interruption for the Faculty Recruitment System (Human Resources Systems).

Support staff are working to resolve the issue as quickly as possible.

The next update will be provided by 13:00 CST.
Posted Mar 07, 2025 - 11:50 CST
This incident affected: Administrative and Business (Faculty Recruitment System (Human Resources Systems)).