NUValidate NETID Services Interruption

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 12:53 CDT

Monitoring

Services are restored at this time. Northwestern Information Technology will continue to monitor for any further issues.

The next update will be provided by 13:00 CDT
Posted Jun 02, 2026 - 10:52 CDT

Identified

Northwestern Information Technology has identified an issue and NUValidate NETID Services are unavailable.

IT support staff are working to restore full service as quickly as possible.


The next update will be provided by 12:00 CDT
Posted Jun 02, 2026 - 10:33 CDT
This incident affected: Identity and Access Management (NUValidate (NETID Services)).