Leverone Hall Reduced Power Redundancy
Update
Our vendor was unsuccessful in fully restoring service and will return once additional parts have been obtained.

Next update will be by Tuesday, October 22 16:00 CDT
Posted Oct 18, 2024 - 11:00 CDT
Update
We are still awaiting scheduling of the remaining repairs at this time.

The next update will be provided on Monday, October 14 by 15:00 CDT.
Posted Sep 16, 2024 - 10:49 CDT
Update
We are awaiting scheduling of the remaining repairs at this time.

The next update will be provided on Friday, August 30 by 15:00 CDT.
Posted Aug 23, 2024 - 12:06 CDT
Update
We are awaiting scheduling of the remaining repairs at this time.

The next update will be provided on Friday, August 16 by 15:00 CDT.
Posted Aug 13, 2024 - 16:32 CDT
Update
Repairs were not fully completed today. We are awaiting scheduling confirmation from vendor when remaining work will take place.

The next update will be provided on Monday, August 12 by 16:00 CDT.
Posted Aug 08, 2024 - 15:40 CDT
Update
Our vendor has obtained parts and repairs are scheduled to be completed Thursday, August 8, 2024 beginning at 09:00 CDT.

The next update will be provided on Thursday, August 8th by 16:00 CDT.
Posted Aug 07, 2024 - 17:27 CDT
Identified
We are awaiting delivery of parts and scheduling of repairs for this issue.

The next update will be provided on Thursday, August 8th by 16:00 CDT.
Posted Aug 06, 2024 - 15:52 CDT
Investigating
Northwestern Information Technology has monitored a loss of redundancy to the uninterruptable power system serving the Leverone Hall facility. There is currently no service interruption due to this issue. Support staff are working with vendor support to restore the affected module quickly as possible.

The next update will be provided on Tuesday, August 6th by 16:00 CDT.
Posted Aug 05, 2024 - 18:36 CDT
This incident affects: Infrastructure (Electrical Systems (Data Center Facilities)).