Blackthorn Events Service Interruption

Resolved

The vendor has confirmed this incident has been resolved.
Posted Nov 18, 2025 - 11:24 CST

Monitoring

We are beginning to see services restore for Blackthorn Events

The vendor has implemented a fix but has not yet declared the incident resolved.

Northwestern IT will continue to monitor services until vendor as announced the incident resolved.

The next update will be provided by 11:30 CST.
Posted Nov 18, 2025 - 10:11 CST

Identified

Northwestern Information Technology has identified an issue causing a service interruption for Blackthorn Events (Alumni and Advancement). While the vendor is working to resolve this issue as quickly as possible, we have not yet received a project resolution time.

The next update will be provided by 10:30 CST.
Posted Nov 18, 2025 - 09:26 CST
This incident affected: Administrative and Business (Blackthorn Events (Alumni and Advancement)).