TeamDynamix Degraded Service

Resolved

The vendor has confirmed that services were restored, and services are back to normal operation at this time.
Posted Jun 02, 2025 - 12:26 CDT

Investigating

Northwestern IT is investigating an issue with Team Dynamix. Agents are currently experiencing issues connecting to and using the ticketing side of the TeamDynamix application. We're working with the vendor to identify and remediate the issue. The knowledge base and other public-facing areas continue to be accessible.

The next update with be at 12:00 CDT
Posted Jun 02, 2025 - 08:03 CDT
This incident affected: Professional Services (Service Management Platform (Service Delivery and Support)).