2220 Campus Drive 2nd Floor Network Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved for wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive. Service was fully restored at 15:00 CDT.
Posted Sep 24, 2023 - 14:54 CDT
Monitoring
Northwestern Information Technology is seeing improvement in service delivery for wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive and will continue to monitor until the issue is resolved and service is fully restored

The next update will be provided by 16:00 CDT
Posted Sep 24, 2023 - 14:54 CDT
Update
Northwestern Information Technology is continuing to work on resolving an issue affecting wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive. The next update will be provided by 15:00 CDT.
Posted Sep 24, 2023 - 11:32 CDT
Update
Northwestern Information Technology is continuing to work on resolving an issue affecting wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive as soon as possible. The next update will be provided by 12:00 CDT.
Posted Sep 24, 2023 - 00:40 CDT
Update
Northwestern Information Technology is continuing to work on resolving an issue affecting wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive as soon as possible. The next update will be provided by 01:00 CDT.
Posted Sep 23, 2023 - 22:51 CDT
Update
Northwestern Information Technology is working to resolve an issue affecting wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive as soon as possible. The next update will be provided by 23:00 CDT.
Posted Sep 23, 2023 - 20:39 CDT
Identified
Northwestern Information Technology has identified a service interruption for wired, wireless, and telephone services on the second floor of Cook Hall at 2220 Campus Drive. A technician has been dispatched to resolve an issue with a network switch. The next update will be provided by 21:00 CDT
Posted Sep 23, 2023 - 18:02 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).