Campus Email Delay Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved.
Posted Apr 17, 2024 - 08:44 CDT
Identified
Northwestern Information Technology is monitoring services and is no longer observing the issue. Alerts are set up for recurring issues and we will continue to monitor email services.

A final posting will me made by 09:00 CDT 04/17/2024.
Posted Apr 16, 2024 - 22:13 CDT
Update
Northwestern Information Technology is continuing to investigate this issue.

The next update will be posted by 09:00 CDT 04/17/2024.
Posted Apr 16, 2024 - 21:56 CDT
Investigating
Northwestern Information Technology is investigating delays impacting a percentage of external emails as well as emails that pass through our campus relay (bulkmail, listserv, etc.). Internal emails between Exchange users are not affected.

IT support staff are working to restore full service as quickly as possible.

The next update will be provided by 22:00 CDT.
Posted Apr 16, 2024 - 21:01 CDT
This incident affected: Communication and Collaboration (Email Marketing and Campaign Management (Bulkmail) (Mass Communications), NU Listserv (Mass Communications)).