Some Service Outages at 2705 Ashland
Resolved
This outage at the posted location has been resolved & all services should be working as expected.
Posted Dec 03, 2024 - 11:25 CST
Update
We are continuing to investigate the issue

Next update will be posted once it's available
Posted Dec 03, 2024 - 11:02 CST
Update
We are continuing to investigate the issue

Next update will be at 11:00 CDT
Posted Dec 03, 2024 - 10:00 CST
Investigating
Northwestern Information Technology has monitored an outage at the posted location and is actively working to restore service

Next update will be at 10:00 CDT
Posted Dec 03, 2024 - 08:55 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).