Power and services have been restored to all locations.
Posted May 18, 2026 - 13:03 CDT
Update
At this time a number of locations on the Evanston campus have lost power to network devices.
Affected services include network connectivity including VoIP phone, wireless, and wired services,
Next update will be posted by 13:00 CDT
Posted May 18, 2026 - 12:03 CDT
Identified
Northwestern Information Technology has monitored an interruption of utility power to portions of the Evanston Campus. All services remain online at this time without power redundancy. Affected services include network connectivity including VoIP phone, wireless, and wired services,
Next update will be posted by 12:30 CDT
Posted May 18, 2026 - 11:42 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).