Student Opportunity Application Platform Service Interruption

Resolved

Northwestern Information Technology has continued to see normal performance for the Student Opportunity Application Portal and we are resolving this posting.
Posted May 20, 2026 - 08:18 CDT

Monitoring

Northwestern Information Technology has confirmed that the Student Opportunity Application Platform is recovered and available. The vendor is currently working to identify a root cause. We will continue to monitor performance and will provide an update by tomorrow at 09:00 CDT.
Posted May 19, 2026 - 09:37 CDT

Investigating

Northwestern Information Technology and the vendor are currently investigating an issue effecting the Student Opportunity Application Platform. The vendor is aware of the issue and is working to identify a fix. The next update will be posted by today by 11:00 CDT.
Posted May 19, 2026 - 08:34 CDT
This incident affected: Administrative and Business (Student Opportunity Application Portal (Research Administration Systems)).