Talkdesk Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved. Service was restored at 14:09 CDT.
Posted Jun 11, 2024 - 14:24 CDT
Identified
Northwestern Information Technology has identified an issue with Talkdesk impacting a subset of services. The Talkdesk service is used by a number of call centers and help desks across the University. Due to this incident, callers may experience longer than expected wait times.

The next update will be provided by 14:30 CDT.
Posted Jun 11, 2024 - 13:17 CDT
This incident affected: Voice Services (Call Centers (Videoconferencing and Telephones)).